You need the latest version of flash!